无法从 AutoCAD 产品打印某些 OLE 对象和嵌入的图像

Autodesk Support

2025年2月19日


涵盖的产品和版本


问题:

用户指出,从 AutoCAD 打印包含 OLE 对象的图形时,其中一个或多个对象无法打印。打印或发布到物理打印机或 PDF 时,会发生这种情况。此外,还可能出现以下情况:
  • 缺少的图像在模型空间、布局和打印预览中可见。
  • 保存、关闭并重新打开 DWG 文件后,该图像似乎已从图形中删除。
  • 每次打印时都缺少不同的图像。 
  • 放大和缩小或单击空白区域后,图像可能会重新显示在 PDF 中。 
  • 可能会显示以下警告:“警告: 无法光栅化图像以进行打印。”
警告: 无法光栅化图像以进行打印
 

原因:

  • OLE 输出与打印机驱动程序之间的分辨率不同。
  • 打印机驱动程序分辨率设置低。
  • 在 AutoCAD 中旋转了页面方向(纵向或横向),但在打印机驱动程序中没有。
  • 工作站或绘图仪上的系统资源不足。 
  • 计算机只有一个集成显卡。
  • 由非 Autodesk 产品创建的对象。 
  • 从其他软件(Word、Excel 等)复制大量信息并粘贴到 AutoCAD 中。
  • 绘图仪驱动程序已过时。
  • PDF 查看器无法显示对象。 
  • 防病毒/防火墙阻止 AutoCAD。
  • AutoCAD 及其专业化工具组合缺少更新。
  • 非 Microsoft 网络环境。 

解决方案:

更改受影响 OLE 对象的“打印质量”设置

  1. 选择 OLE 对象。
  2. 打开“特性”窗口。
  3. 将“打印质量”更改为“高质量图形”。
注意:任何设置都可能出现不同的效果,但通常建议使用“高质量图形”。

提高打印机分辨率

  1. 在命令行中输入 PLOT 以打开“打印”对话框。
  2. 选择“打印机/绘图仪”,然后单击绘图仪名称旁边的“特性...”。
  3. 在“设备和文档设置”选项卡中,选择“自定义特性”,然后单击“自定义特性...”。
  4. 如有可能,提高分辨率 (DPI)(对于每个设备/打印机驱动程序,选项会有所不同;查看特定打印机文档以获取帮助):
    • 对于 AutoCAD PDF 驱动程序,提高“矢量图像质量”和“光栅图像质量”的 DPI。
    • 对于物理打印机/绘图仪,调整“详细设置”>“打印质量”(如果可用)。
该图像显示了“设备和文档设置”。

该图显示了如何更改物理打印机/绘图仪的打印质量。
 

降低打印机分辨率

  1. 在命令行中输入 PUBLISH 以打开“发布”对话框。
  2. 单击“发布选项”。
  3. 降低矢量图像质量和/或光栅图像质量的 DPI。
  4. 单击“确定”进行确认。

调整 OLE 对象大小

稍微放大或缩小 OLE 对象。可能需要使用 Microsoft 画图工具编辑图像。

减小页面大小

使用较小的页面大小进行测试,以便使用较少的系统资源。

从原始图像创建图像

  1. 使用 Windows 截图工具或其他图像捕捉软件来创建图像的副本。 
  2. 从文件中删除原始图像。 
  3. 附着新的截图。

新建图形

  1. 创建图形。
  2. 将现有图形(包括嵌入的 OLE 对象)插入到此新图形中。

现有图形

  1. 删除现有图形中的 OLE 对象。
  2. 使用 IMAGEATTACH 命令将 OLE 对象作为光栅图像参照插入。

清理 Windows 和 AutoCAD 图形缓存临时文件夹。

  1. 清理 Windows TEMP 文件夹。请参见如何删除 Windows 中的临时文件
  2. 清理 AutoCAD 图形缓存文件夹。请参见如何通过清除图形缓存解决显示问题

由非 Autodesk 软件创建的对象

  • 如果对象包含在块中,请对块执行 EXPLODE 并尝试打印。
  • 在图形中创建一个打印的对象,使用 MATCHPROP 匹配新对象的特性。 

    确保计算机具有专用显卡

    请参见:认证图形硬件

    更新绘图仪驱动程序

    检查绘图仪制造商的网站,以在当前操作系统下获取绘图仪的建议驱动程序。请参见:如何获得用于 AutoCAD 的相应打印机驱动程序

    防病毒或防火墙可能阻止该软件,添加例外以放弃作为根源的防病毒软件。

    更多系统疑难解答

    • 测试不同的打印机。
    • 在其他 PDF 查看器中查看 PDF。 
    • 增加绘图仪内存。
    • 将打印内容发送到内存更大的设备。
    • 增加工作站上的交换文件大小。
    • ​将打印设备驱动程序设置为“在计算机中处理”。
    • 从源软件复制少量信息(电子表格单元、文本内容和其他数据)。
    • 打印到网络环境时,请尝试打印到本地驱动器。 

    更多疑难解答

    • 下载并安装适用于您所用 AutoCAD 软件的最新 Service Pack 和任何 Hotfix。请参见安装更新、附加模块和增强功能
    • 如果自定义设置已添加到 AutoCAD,请尝试如何将 AutoCAD 重置为默认值
    • 如果重置不起作用,请完全卸载并重新安装 AutoCAD,然后在不将自定义设置添加回 AutoCAD 的情况下进行测试。 
    • 将 BACKGROUNDPLOT 设置为 0
    • 如果着色打印设置在视口特性菜单中设置为隐藏,则在“其他”部分下将隐藏的着色打印更改为“按显示”

    产品:

    AutoCAD 产品


    此信息是否有用?


    需要帮助?请求助 Autodesk 助手!

    助手可以帮助您找到答案或联系支持人员。


    您享有什么级别的支持?

    不同的固定期限使用许可方案提供了不同级别的支持。了解您的许可方案提供的支持级别。

    查看支持级别