“Revit 无法运行外部应用程序...”打开 Revit 时

Autodesk Support

2025年4月18日


涵盖的产品和版本


问题:

打开 Revit 时,显示以下消息:

外部工具 - 外部工具失败

Revit 无法运行外部应用程序 <应用程序名>。 Contact the provider for assistance.他们向Revit提供的有关其身份的信息:<信息>

Revit 无法运行外部应用程序 <应用程序名>。请联系提供程序寻求帮助。他们提供给 Revit 的身份<information>信息:”

 

  • 日记帐显示类似于以下内容的行:

TaskDialog "Revit cannot run the external application "application name". Contact the provider for assistance.  Information they provided to Revit about their identity: "applicationname."
'Id : TaskDialog_External_Tools_External_Tool_Failure

 

原因:

无法载入 Revit 中安装的附加模块。

解决方案:

禁用附加模块

  1. 有关如何如何禁用 Revit 的附加模块的信息,请参见以下文章

  2. 如果根据消息中的名称找不到附加模块,请禁用所有附加模块并确认警告已清除。接下来,重新启用它们以找到导致问题的原因。

  3. 如果不需要该附加模块,请将其禁用或通过“应用和功能”(在 Windows 设置中)将其卸载

  4. 如果需要附加模块,请通过应用程序和功能(在 Windows 设置中)将其卸载,然后重新安装最新版本的附加模块并测试问题

  5. 如果在重新安装最新版本的附加模块后警告仍然存在,请与附加模块的制造商联系,以进一步进行疑难解答。

     

更新 Revit

安装 Revit 的最新更新和 Hotfix:更新 Autodesk 软件。

 

重置 User.config

如果警告列出了引用 用户.config 的异常,如下所示:
System.Configuration.ConfigurationErrorsException:'.',十六进制值0x00,是无效字符。第 5 行,位置 1。
(C:\Users\\AppData\Local\Autodesk,_Inc.\DefaultDomain_Path_\\用户.config第 5 行) ---->System.XML.XMLException

错误详细信息: “System.Configuration.ConfigurationErrorsException”

完成以下文章中的步骤以重置 用户.config 文件:尝试在 Revit 中打开任何云模型时发生崩溃。

 

      产品:

      Revit 产品系列


      此信息是否有用?


      需要帮助?请求助 Autodesk 助手!

      助手可以帮助您找到答案或联系支持人员。


      您享有什么级别的支持?

      不同的固定期限使用许可方案提供了不同级别的支持。了解您的许可方案提供的支持级别。

      查看支持级别